I don't see why it would be worthwhile to do so. If I rename a service, I am still using
:GetService() which means that I will be doing the same amount of typing for the name. If he was doing it so that using
game.SS would be easier, that was not a good reason to change the name of the service. It is better practice to use
:GetService() as explained so eloquently by M39a9am3R in his answer to my question. Also, you should be using variables if you need to make the name easier to type. If you are typing
ServerStorage enough to need to change the name, you are typing it to much. A variable is a much better way to go. Honestly, I can think of no decent reason why renaming a service would be helpful. Because it is not useful and not convention (from what I have seen), it is bad practice.
Quick note about
:GetService(): It is very important to use on the client because the client can change the names of scripts, and if you use
:GetService(), you will be able to protect against your scripts being broken.